Extended crank but no start issue

Have you experienced a ECNS


  • Total voters
    13

huskrbill

New member
4
2
Year
2021
So far it seems to have changed how fast every start rpm is. Used to be if it fast cranked I got a no start. Now every start is a fast crank but it has started Everytime so far.
 

asimpson997

New member
5
0
Year
2021
So there is an ECM flash for this now? I have had the issue 4 times now over 4 months of owning my 2021 GMC Sierra
 

Kwalk1959

New member
21
3
Year
2021
I followed the posts about EC/NS issue, and hoped against hope that it would not happen to me. Also, I never posted in the threads for fear of jinxing myself. Well, yesterday, it happened. My 2021 Sierra 1500 LM2, with a warm engine, experienced the EC/NS. Crap! 724 miles on the vehicle, 3 weeks old. And just like all the others, it fired right up on the second try. I immediately drove to the dealer, which was only 3 blocks away, and had them document the issue. The service manager said they had only seen one other case, and they reflashed the guy's computer. I guess I will have them do the same when I take mine in for the free first oil change, although I really do not expect it to resolve the issue. Meanwhile, I keep following these EC/NS threads....
Have you had any additional no starts??
 

GreenTruck

New member
3
0
Year
2021
Has anyone had their 3.0 L Duramax Cam Shaft Accelerator replaced? My dealer has ordered the parts a month ago, still waiting.
 

BoostN

Administrator
Staff member
292
47
TN
Year
2021
Mines a 2020 and I have had it happen 3 or 4 times now with no codes. Dealer hasn’t heard anything about the problem

Thanks for reporting back. A friend of mine has a 2020 and has never had the issue.
 
  • Like
Reactions: Tom

GreenTruck

New member
3
0
Year
2021
I have a 2021 Sierra Denali 1500 ultimate package 3.0L Duramax in Hunter green metallic. No codes when the issue happened. Still waiting on the dealer to get all the parts. Scary thought on how it will have to be replaced...
 

gemarsh

Nebraska, where the Dusty Denali Diesel's roam.
Staff member
283
98
Nebraska
Year
2021
I have a 2021 Sierra Denali 1500 ultimate package 3.0L Duramax in Hunter green metallic. No codes when the issue happened. Still waiting on the dealer to get all the parts. Scary thought on how it will have to be replaced...
Have you seen the other thread on this subject about the PIP5823B?

I for sure would try the Oct. 4th re-flash, before they ripped my cab off.
 

Mooseman

New member
4
2
Ottawa, ON Canada
Year
2021
Mine's at the stealership now with 1700km on the odo after CNS twice in a couple of days. Service rep I talked to seemed totally clueless as to this issue. I mentioned the latest ECM update that could fix this. Sure hope it's not the bent cam gear issue some have had. Will update once I get it back.
 

BoostN

Administrator
Staff member
292
47
TN
Year
2021
Mine's at the stealership now with 1700km on the odo after CNS twice in a couple of days. Service rep I talked to seemed totally clueless as to this issue. I mentioned the latest ECM update that could fix this. Sure hope it's not the bent cam gear issue some have had. Will update once I get it back.

Most service advisors are clueless sadly.. "Enthusiasts" like ourselves likely know more then them about specific bugs/gotchas as we live and breath these things.
 
Top